🎄 Spruce up your content with image resizing in Control

Related products: Topic creation
  • 18 December 2020
  • 6 replies
  • 311 views

You can now resize and align images in the Control WYSIWYG editor!

With the new improvements, you can:

:white_check_mark: Resize images in your articles, product updates, and replies to end users.

:white_check_mark: Align images and text left/centre/right in your articles, product updates, and replies to end users.

In particular we hope this update helps those of you who need to deal with screenshots uploaded from mobile, which often take up a lot of space and make topics unreadable! As a small followup, we’re also working on an automatic height limitation for images uploaded by end users on mobile.

Thanks @ThomasMalingre for submitting this idea, and @bjoern_schulze @Marina Perminova @Ben Anthonisz for your especially enthusiastic support of the idea :wink: .

Here’s a collage of images to demo image resizing/alignment in action - a special thank you to all the product engineering inSiders who modelled for our #worst-xmas-sweater competition for letting me use these festive photos :christmas_tree:.

THANK YOU! :pray:


Finallyyyyy!! Thank you :blue_heart:

Love the photos :smile::heart_eyes::christmas_tree:


As @Marina Perminova said, FINALLY!
I was tired of editing every image before uploading. Great job, teams! :clap_tone2:


Amaaaazing. I came for the feature release, but stayed for the sweaters :heart_eyes:


@daniel.boon I think this is causing a problem with creating events, because I can’t get my images to work. It shows too big in the editor window, with no way for me to resize. Before this update, my image actually fit with no resizing needed. But now, when I upload it’s too big and there’s no way to resize it because the window is too small. Here’s what I see:

event setup image

 

Something isn’t right and I’m not sure if it’s Chrome. Because as I’m writing this now, the image above my text is bouncing around (and stopped once I added a caption) and I’m apparently unable to resize it by dragging edges - it doesn’t even show in the WYSIWYG editor.

I’m using this version of Chrome on a Mac:

Google Chrome is up to date

Version 87.0.4280.88 (Official Build) (x86_64)

 

EDIT: Update to note that if I go ahead and save, it eventually renders properly in the post. But I still cannot resize in the window.


Thanks for letting me know @becky.scott! This is unexpected behaviour - I’ve raised a support ticket on your behalf.