Announcement

Uploading GIFs is back! 🤖👾👻

  • 20 December 2018
  • 28 replies
  • 413 views

Userlevel 7
Badge +1
GIFs are once more available on the inSided platform!

Sorry it took longer than expected to resolve this - hopefully you still have enough time to post some Christmas GIF(ts) on your communities! 🎅🤶!



28 replies

Userlevel 3
Badge +1
Awesome! I love GIFs! 🙂

Userlevel 7
Badge +4
As we're a new customer I would like to clarify what the fix does. My understanding (and testing) is, that it's now possible (again) to upload GIFs using the "Insert Image" function of the editor, but it is not possible to just copy&paste a GIF url into the editor field and the url will automatically be converted into the actual GIF. Correct?
Userlevel 7
Badge +1
As we're a new customer I would like to clarify what the fix does. My understanding (and testing) is, that it's now possible (again) to upload GIFs using the "Insert Image" function of the editor, but it is not possible to just copy&paste a GIF url into the editor field and the url will automatically be converted into the actual GIF. Correct?

That's correct - this fix allows you to upload GIFs from your local files to the community (the functionality we previously had available).
Userlevel 3
Badge +1
I did just copy and paste the gif directly into the reply field and it seems to work on this end.
Userlevel 2

Userlevel 6
Badge +3

Userlevel 3
Badge +1


GIF's are so good 😍
Userlevel 7
Badge +1
I did just copy and paste the gif directly into the reply field and it seems to work on this end.

That's also true Samuel - what you've described is basically the easier equivalent of the workaround Julian suggested whilst GIF upload wasn't working.

So, it is also possible to copy the GIF and paste it in the editor (the image itself, not the URL).

The reenabling of GIF upload described in this topic is most useful if you have a GIF that you need hosted on our platform (i.e. you made the GIF yourself, or you don't want to rely on an external host) 😀
Userlevel 7
Badge +4
I did just copy and paste the gif directly into the reply field and it seems to work on this end.
Do you mean the BBCode workaround? Or how would you copy & paste a GIF directly?
Userlevel 3
Badge +1

I did just copy and paste the gif directly into the reply field and it seems to work on this end.Do you mean the BBCode workaround? Or how would you copy & paste a GIF directly?


I literally right clicked and copied a GIF that I saw in the Google search results then right clicked and pasted it into a reply (the above Spongbob GIF)
Userlevel 7
Badge +4

Userlevel 6
Badge +3
https://media2.giphy.com/media/xTiTnzEhdR9y9PNyc8/200w.webp?cid=3640f6095c1c9445574a666345febbc5

YASSS!! Copy+paste does indeed work!
Userlevel 6
Badge +3
https://media2.giphy.com/media/xTiTnzEhdR9y9PNyc8/200w.webp?cid=3640f6095c1c9445574a666345febbc5

YASSS!! Copy+paste does indeed work!

Or does it? I do see the gif in the editor, but I only see the link to the GIF in my reply ⬆
Userlevel 3
Badge +1
https://i.giphy.com/media/xTiTnzEhdR9y9PNyc8/200w.webp
Testing

Edit // Didn't work with cleaned URL (took out the ?cid=3640f6095c1c9445574a666345febbc5 part)
Userlevel 3
Badge +1
https://i.giphy.com/media/xTiTnzEhdR9y9PNyc8/200w.webp
Testing

Edit // Didn't work with cleaned URL (took out the ?cid=3640f6095c1c9445574a666345febbc5 part)

Maybe it's the .webp format?
Userlevel 3
Badge +1
Test number 2

Userlevel 3
Badge +1
Test number 2


@Suvi Lehtovaara it works when you use .gif format, if you use .webp it shows in edit but not in comment
Userlevel 4
Badge +2
@daniel.boon , Nice feature. Do we have to enable it or is their an option for us to not allow GIFs?
Userlevel 7
Badge +1
@daniel.boon , Nice feature. Do we have to enable it or is their an option for us to not allow GIFs?

Hey Claudia - there's no way to prevent GIFs from being uploaded on the platform at the moment. Currently the ability to upload GIFs is coupled with to the general ability to upload images, with no way to configure the types of image that may be uploaded.
Userlevel 7
Badge +1
@Patomiäs I think this is not working because giphy is proctecting their gifs from being shared this way. That's also why the url is not pointing to an actual gif.

@Claudia.Willunat Currently there is no option to disable gifs per default. Never saw issues with it. Most users do not even know that it is supported I think that's why they do not use it that often.
Userlevel 3
Badge +1
Test 3 😅 Checking if the problem is just on giphy ☺
http://littlesvr.ca/apng/images/GenevaDrive.webp
Edit // Nope, editing the comment and while writing it, it shows the webp as should, but on actual published comment it's not working 😕
Userlevel 7
Badge +1
Hmm it's weird because the urls which you are sharing are not ending on .gif, which to me is a hint that there is some type of block. It also seems impossible for me to upload this as a gif in the regular way.

Again I think this is due to protection from the website: They want you to watch that gif on their website, but they do not want you to copy and share that material.

What I always do is right-click the gif and go to "view image", so that it loads only the gif in a seperate tab. This way I know I copy the gif and that it will work.

I have tested it with gifs when the url ended up on .gif when I watch them, and there it worked in 99% of times:

Userlevel 3
Badge +1
The ending .webp is alternative for .gif, .webp is file type made by Google (open source) that has also ability to play back small video snippets in similar way that .gif's work 🙂 So the problem is with the file type that appears in search results when searching for .gif's to use. Many .gif sites seem to have already converted to use .webp, thus it would be nice addition to include support for the platform 😊
Userlevel 7
Badge +1
Aaaah thanks, that was new to me! 😃 I will pass this on so that we can look into it. I know there is some third party involved in this so it might not be totally in our hands, but I will check on that.
Userlevel 5
Badge +4

Reply