Release

Our new text editor is now available on all communities!

Our new text editor is now available on all communities!
Userlevel 7
Badge +1

We are very proud to announce that our completely new editor is now available for all users on all communities! :grin::raised_hands::pencil2: We have invested a lot of time to give you and your users more options to create richer content in an easy way - so we hope that you will enjoy working with the new editor as much as we do!

We are investigating line-height / spacing inconsistencies as well as problems with selecting text on some viewports (e.g. Safari on iOS).

Polls are temporarily not available, but will be added again soon.

 Overview of improvements

There are many things which have improved with the new editor, just to name a few:

Improved existing features

  • Image upload
    • Drag & drop images into the editor instead of manual upload
    • Captions (descriptive text underneath uploaded images)
  • Code
    • In-line code is now possible (previously code was in an extra line)
    • Code syntax (code is not being stripped automatically anymore)
  • Lists
    • Multi-level lists are possible now
    • Better UX in working with lists (previously lists could not be interrupted by line breaks)
  • Text styling
    • Text styling within lists was not fully supported before

New features

  • Tables!
  • Callouts
  • Text color / background color
  • Horizontal lines

Of course not all of these features are available to end users, some of these (e.g. text color, header, callouts) are only available in the Control environment for now. We have plans to make this available to front-end users via user roles in the future, so that you are in control of who can make use of these features - please share your thoughts on this with us in the comments!

Feedback

Please let us know what you think of this improvement, also how your users are feeling about it. This way we can adjust and improve the editor even further in the future!


156 replies

Userlevel 6
Badge +3

One of our superusers noticed the new editor and created a post highlighting the new features & asking what our community members thought about it, much as you’ve done here! :heart_eyes:

The one thing I’ve noticed that’s been challenging for me is that the text size is smaller when I’m typing a reply or writing a new topic. It hurts my (aging) eyes. Is this something I can change on my end?
 

 

Userlevel 6
Badge +3

Good Morning from frosty Helsinki :blush::snowflake:

Our superusers also noticed the new editor and tested the mobile version.

Is it really this simple?

 

Userlevel 7
Badge +4

My previous findings don't seem to be addressed. Not sure why I'd provide feedback at all, really. :rolling_eyes: Seems like you saw it but settled

Here's the feedback from the superusers at KPN:

W:
"What a TERRIBLE editor. No way [on mobile] to copy text, no way to hold or cursive text, no way to insert smileys ... [...] I can't work with this."

D:
"I agree with! This is really a setback. Decisions are made without sharing what we would like in the editor. [...] I see some of the buttons return when using it in landscape mode."

A:
"An editor shouldn't be worse, depending on your device"

W:
"This isn't a setback, this is killing the usage of the forum on phone or tablet. I expect this to be fixed tonight. If this stays the same, you'll be seeing a lot less from me anyway."

D:
"All providers have this, so apparently none of the providers have a say in this. Can't Insided first discuss with KPN?"

S:
"Aahhh, CKEeditor. I have it on my site as well (Except I've tested it a little better there ;))"

A:
"Tablet portrait the attachment feature is gone again. Selecting multiple words doesnt always work correctly. What also strikes me is that when adding an image, you have to pick browse first."

T:
"On PC everything works fine and on iPad I've seen it works OK as well. You wouldn't want to reply to the forum on your phone right? On the other hand, some people do a lot on that small screen ... [...] Let's test on a phone [...] Inserting a photo worked, but you have to use it in landscape. A hassle."
 

Userlevel 3
Badge

We also have comments from our superusers :

  • "I'm on mobile and this version is a disaster full of various bugs: tabulation, emoticons and tags don't work"
  • "When I type a message, the characters are in italics when I didn't press the italic function."
  • "It is not possible to tag some users. You have to try it several times before it works."
  • "It is not possible to tag users with compound pseudos. For example, if I want to tag @Marie S, it doesn't work"
  • "The tag drop-down list is limited and does not show everyone. For example, if I want to tag @Marie S by noting that @Marie I can't because the list stops before"
Userlevel 6
Badge +3

Would it be possible to get a list of “known issues”? 

That would help a lot :)

And for future reference we would highly appreciate knowing a set-time or an estimate of go-live time, as now our superusers (again) were the first ones to notice that the new editor is live :thinking:

While I'm excited about the new features, a problem we see is that the built-in spell checker in browsers (we use Chrome, but tested in Edge too) no longer works anymore. We already see posts coming in with lots of grammar mistakes and words that don't make sense, that a browser would normally correct or highlight. 

 

We would appreciate if the entry field could be modified as such that browsers recognize it as a text field, so the spell checker is automatically activated.

Userlevel 7
Badge +1

Hi all,

thanks to all of you who shared feedback here - this is really appreciated and we are already processing this internally. I will go through it one-by-one instead of posting a massive, unreadable reply.

 

The one thing I’ve noticed that’s been challenging for me is that the text size is smaller when I’m typing a reply or writing a new topic. It hurts my (aging) eyes. Is this something I can change on my end?
 

 

@LPortalupi thanks for reporting this. We are aware of discrepancies between the editor view and the final post. We are looking into it as we ideally want the editor to show 1-1 how it will look once published.

Userlevel 7
Badge +1

General response to mobile viewport feedback :arrow_down:

We appreciate your feedback and we are looking into it:

  • I am gathering more information on how it behaves exactly (at which pixel size it reduces the features) and how it behaved before so that I can share it here with you. This is for general reference so that we all understand how it behaved before vs. now.
  • The team is already investigating this so that your users will have a better mobile experience going forward. This probably will result in offering more editing features also on smaller viewports. I will keep you updated with more specific information once it comes in.

My previous findings don't seem to be addressed. Not sure why I'd provide feedback at all, really. :rolling_eyes: Seems like you saw it but settled.

@Jurgen I surely accept criticism on the fact that this has not been prioritized correctly on our side, this is something we can improve. Nevertheless, it is not the case that we do not follow up on the feedback shared here. We actually discussed your feedback in great lenght internally, I was part of that discussion, so rest assured that we take your feedback with. Looking at that thread you linked to, my colleague has responded in detail to all of your comments.

Again, we are working on improving this (never settle, he? 😉 ), however I feel that the feedback of your users is also due to the fact that on the previous editor, your community had custom code which gave your users these additional editor features also on the mobile view.

This custom code is now broken in the new editor as we do not support this ourselves. My colleague actually even informed you about this in advance in one of his replies:

Custom code written to make changes to the default behaviour of our platform is not always supported with the continuous updates of our platform. We rewrote parts of the editor to support more and new functionality, therefore your custom code to show featurs on mobile is probably not working. (This needs to be rewritten..)

I hope that our improvements to the mobile experience will help in decreasing the negative feedback from your users, however we cannot be sure that this will be enough given your users expect something we did not offer in the first place.

Userlevel 2

General response to mobile viewport feedback :arrow_down:

We appreciate your feedback and we are looking into it:

  • I am gathering more information on how it behaves exactly (at which pixel size it reduces the features) and how it behaved before so that I can share it here with you. This is for general reference so that we all understand how it behaved before vs. now.

I hope that our improvements to the mobile experience will help in decreasing the negative feedback from your users, however we cannot be sure that this will be enough given your users expect something we did not offer in the first place.

 

767 pixel breakpoint, it removes more or less all features.

I already changed the mobile options myself.

 

Fixing the selection on mobile devices would be much appreciated though :-)

Userlevel 7
Badge +1

Hi @Marie S, now to your feedback:

  • "I'm on mobile and this version is a disaster full of various bugs: tabulation, emoticons and tags don't work"
  • "When I type a message, the characters are in italics when I didn't press the italic function."
  • "It is not possible to tag some users. You have to try it several times before it works."
  • "It is not possible to tag users with compound pseudos. For example, if I want to tag @Marie S, it doesn't work"
  • "The tag drop-down list is limited and does not show everyone. For example, if I want to tag @Marie S by noting that @Marie I can't because the list stops before"

So I have some findings and some questions around this.

  • If you are mentioning a user that has a blank space in the name (like yours) it could go wrong once you enter a space. This has to do with the fact that this feature needs a signal to stop. We are checking if we can improve this somehow.
  • The issue with writing in italic without selecting it cannot be reproduced - maybe you can ask more details (browser, desktop or mobile, operating system) so that we can follow up? This could also happen if you continue to write in a quote, however this might not be the case here.
  • I have not seen a limitation in the list of mentions, however if you can provide me with a link to the topic where this happens (via pm if it is a hidden area) then I am happy to check on this as well.
  • mobile view does currently not offer tables, so I am not sure how to categorize this. Emoticons on mobile should just use those of the keyboard in use. If you have more details on this as well (browser, device) we can double check on it.
Userlevel 7
Badge +1

Hi @Suvi Lehtovaara,

we are still collecting all feedback, I will work on an overview so that you and others are aware of things that have been reported and/or are being worked on already.

About informing you: We actually sent a mail on thursday last week to give you a heads up, can you check if you received that? I will have a look if I you are missing in the list of recipients, but maybe it just ended up in your spam inbox?

Userlevel 7
Badge +1

@SophieW thanks for sharing this with us as well! My colleagues have received your feedback and will look into it, I will get back to you once I have more information on this subject.

Userlevel 7
Badge +1

Hey @Thomas,

I just checked with the old version of the editor, there it also strips these features at 767px.

Great to see that you already worked on this yourself, however I understand that you rather like us to offer this ourselves. As I’ve said the team is looking into it, will share an update on it asap so you know what we are doing with this.

Userlevel 2

Hey@Thomas,

I just checked with the old version of the editor, there it also strips these features at 767px.

Great to see that you already worked on this yourself, however I understand that you rather like us to offer this ourselves. As I’ve said the team is looking into it, will share an update on it asap so you know what we are doing with this.

I actually reversed your display:none; in the old editor as well ;)

Let me know if and when this is picked up on your end so I can possibly remove the overwrites again. However atm there are much bigger priorities so please don't focus on this one.

 

Userlevel 7
Badge +4

We appreciate your feedback and we are looking into it

 

I assumed what@Yoeri meant here was that an update on staging would be released with the fixes the developers were working on (I couldn't imagine you'd release an unfinished feature to the masses). Therefore I didn't realize how urgent an update of the custom code was. Also, I asked for help for fixing this and got no response. 
My colleague was just as surprised as I was to see the editor live monday evening, but thankfully he quickly provided a fix :) 

 

I surely accept criticism on the fact that this has not been prioritized correctly on our side, this is something we can improve. 

:thumbsup:

 

It is not the case that we do not follow up on the feedback shared here.


My bad, I should have been more specific. You settled on releasing this version of the editor on production instead of fixing the bugs before releasing it and verifying that customers - at least the ones who provide feedback - are ready for it.

Userlevel 2

There is also an issue with mentioning, especially in the backend. Before, when typing the '@’, you would see a short list of all users who have been active in that topic. Now the list is very long and has all users in all of time and existence. In the frontend is doesn't seem to happen that way. 

Usernames with a space in it seem to be an issue too, the mention-menu disappears after hitting the spacebar. 

Userlevel 7
Badge +1

Thanks for elaborating, @Jurgen!

While I understand that you reported this as an issue, for us this (limited text editing features on mobile viewports) was categorized as a change request, not as a bug. Actual bugs with the editor (e.g. selecting text on specific mobile viewports) have been logged and categorized accordingly to their actual impact. We would not release an improvement if we see that the impact is affecting all users or the core functionality. In this case, we identified two bugs which were not critical enough to stop the release from happening:

  • issues with selecting text on certain combinations of mobile device & browser
  • discrepancies in spacing / line-height in edit view & published post

We acutally did work on some things and released them on-the-go to your staging environment (e.g. better image upload, localization, etc.), and even send an email last thursday to ensure that everybody is informed and can take action until the release is performed.

Once more, I acknowledge that your feedback could have been a signal to us that this change (being more strict with mobile viewport borders) would have a bigger impact on the end user experience, however we ultimately did not regard it as having an impact of this scale. Surely a learning we ideally would have liked to do without the ramification on your users’ sentiment.

Now about the custom code:

I’m sorry to hear that we failed to help you adjusting the code to work in the new editor. 😕 Usually we acutally provide this extra service with no issues, however we are always pointing out that we cannot assure that your custom code will work once we update something, as stated in the TPS page in the Control environment:

Note: We recommend inviting a professional web developer to work with third-party scripts. Insert scripts at your own risk, and proceed with extreme caution —  inSided support won’t be able to assist you with third-party scripts issues. If you want to test your code before publishing we strongly recommend you to use your staging environment first.

Next time you feel left alone with issues around scripts (or in general, really), please drop me a private message and I promise I will help you out as good as I can! :)

Userlevel 7
Badge +1

Hi @Jasper,

thanks for flagging this. We are in the process of deploying a fix for the issues around @-mentions and “space” in usernames. I am not sure about the other issue you are reporting, I cannot reproduce it. I will test and get back to you on this, maybe you can test once I have confirmed that the first fix for the issues around mentioning has been published.

Userlevel 2

Hi @Julian, I had send it to the support address before posting it here. Cristina replied that the dev team is on it. I think they were able to reproduce it:

We have noticed, indeed that in Control the @-mentions does not display a list of contributors anymore, and that usernames containing a space cannot be selected as the action is stopped. The dev team has already started working on fixing these issues. 

Userlevel 3
Badge

So I have some findings and some questions around this.

  • If you are mentioning a user that has a blank space in the name (like yours) it could go wrong once you enter a space. This has to do with the fact that this feature needs a signal to stop. We are checking if we can improve this somehow.
  • The issue with writing in italic without selecting it cannot be reproduced - maybe you can ask more details (browser, desktop or mobile, operating system) so that we can follow up? This could also happen if you continue to write in a quote, however this might not be the case here.
  • I have not seen a limitation in the list of mentions, however if you can provide me with a link to the topic where this happens (via pm if it is a hidden area) then I am happy to check on this as well.
  • mobile view does currently not offer tables, so I am not sure how to categorize this. Emoticons on mobile should just use those of the keyboard in use. If you have more details on this as well (browser, device) we can double check on it.

Thanks for the feedback, @Julian !
1. This is strange because there was no problem before the change of the text editor.

2. I asked the superusers to test again to see if the problem recurs.

3. This happens in all topics. We can't go any lower than the nickname below


4. Okay for the tabs. Emoticons did not send properly but i'll ask superuses if this still happens. For the rest, here is what appears on mobile (iPhone and Samsung) :

 

Userlevel 7
Badge +4

I’ve also gathered feedback and questions from our moderators, super users and myself:

  1. Emoticons don’t always seem to be converted from text to icon. Well provide examples when we experience it again
  2. The new editor has a complete new behaviour regarding hitting “enter”. Formerly a new line was started, never a new paragraph. Now hitting “enter” creates a new paragraph, while hitting “shift+enter” starts a new line. That’s ok for us, but: The margin-bottom for paragraphs is 8px, which is not much. Are you planning on increasing the margin-bottom globally?
  3. Font colors can be set in the editor in Control. Are you planning on letting customers configure the chooseable colors? Because then every customer could define own “corporate” colors to create a color palette that fits the company’s style guide.
  4. File Uploads: Until recently every customer could decide whether to activate file uploads for their community. We opted out of it because of data protection issues. Will we be able to opt out of the file upload function again soon? We really, really, really don’t want our users to upload private files (such as invoices or contracts) to the public.
  5. Mobile view: We are currently gathering information what formatting functionalities are a must for our community users to have on mobile and we’ll provide the list soon.
  6. Default text: In the old editor we could place a default text within the text field (via phrases) to give users some guidance about what to write and what not to write. This is missing now. Can you please add the default text again and make it configurable via phrases?
  7. Submit button left instead of right: What is the idea behind the new position?
Userlevel 6
Badge +3

We also have comments from our superusers :

  • "When I type a message, the characters are in italics when I didn't press the italic function."
  • "It is not possible to tag users with compound pseudos. For example, if I want to tag @Marie S, it doesn't work"
  • "The tag drop-down list is limited and does not show everyone. For example, if I want to tag @Marie S by noting that @Marie I can't because the list stops before"

I’m also noticing the above issues – the italics has been particularly frustrating – I’ve tried many ways to get text to appear Roman (non-italics) after using italics, and it takes me minutes of trial and error before I get it to work. 

Userlevel 6
Badge +3

I’ve also gathered feedback and questions from our moderators, super users and myself:

  1. Default text: In the old editor we could place a default text within the text field (via phrases) to give users some guidance about what to write and what not to write. This is missing now. Can you please add the default text again and make it configurable via phrases?
  2. Submit button left instead of right: What is the idea behind the new position?

+1 to these two points – we would really like to be able to include default text wtihin the text field to give community members guidance, as well as to tell them that they only have 1 hour to edit their post once published.

Userlevel 6
Badge +3

Oh, and another observation that I also mentioned in this other post@Yoeri mentioned that it would be looked into, just wanted to keep it on your radar. 🙂 Hyperlinks are opening in the same window rather than a new tab, unlike before. Sometimes there are links to external resources but I want to keep our community open as a tab on our community members’ browser so they can easily return to what they were doing. Thank you. :slight_smile:

Userlevel 7
Badge +4

Some new findings:

  • The control bar at the top really isn't an improvement in my opinion. It's a nuisance when you're making a long post.
  • Also, I'm noticing the icons are jumbled in the control bar. In particular: the u is out of place and there's a gap between the icons for quotation and ellipsis.
  • Besides selecting text, right click cutting, copying and pasting doesn't seem to work correctly. (link)
  • In a marked answer, someone's bold text seems to have jumped to the right. (link)

I can't upload images right now(?), so text will have to do I guess.

 

 

Reply