Disabling access to categories for custom roles does not work

  • 8 July 2019
  • 5 replies

Userlevel 1

We have started to experiment with custom roles on our community in order to split up our moderator teams based on their expertise.

To do this we wanted to create a custom role that only has access to certain categories, meaning that categories outside of their skill shouldn't even be visible.

Sadly this does not seem to work.

What we did:

  • Created the custom role ADMIN1 and have forum moderation, forums and ability to upload files enabled.
  • Enabled the custom role for a specific user (tested for users with the Moderator and Super User main roles).
  • Disabled access to all categories (except one) for the custom role. Users with the ADMIN1-role shouldn't even see any categories aside from one.
The user with the custom role still has access and no categories are actually hidden for them. Even when we change main role from moderator to super user and disable access to everything for super users, nothing seems to change.

Are we doing something wrong, or is this a bug?

5 replies

Userlevel 3
Hi Yannick, just going to respond to you through the support ticketing system - lookout for a response in your inbox in the next couple of minutes 🙂
Userlevel 3
Hi @Yannick Biesemans ! I've sent you yesterday an email from our support email address. Did you receive it? It might have arrived in your spam folder. Let me know if you have any issue finding it!
Userlevel 1
Hi @Cristina

Thank you for the follow up. I've received a mail but it was just a general 'Thanks for reaching out to inSided support team' message.

i'm assuming you've also sent another mail, but that one hasn't arrived. I checked my spam folder, but that's empty, although there is always the possibility that it was held back by our internal mail protection. 🙂
Userlevel 3
Hmm, I thought something might have interfered in you receiving my email 🙂 Could you please copy paste the question above in an email to and I'll get back to you on that one.
Thanks a lot!
Userlevel 1
Will do, thanks!