Question

Adding links to images

  • 29 January 2020
  • 1 reply
  • 50 views

Hi,

Instead of simply guiding our members to different pages (outside of our community) by adding a link to a piece of text, we wanted to add a little bit more flair by creating buttons and images to click.

However when we add the image to a post and add the link, it won’t open simply by clicking the image. Instead an image preview opens.

Is there a workaround for this? Can we somehow disable the image preview? Adding the link itself seems to work, since right clicking the image and choosing to open the link in a new tab actually opens the correct page.


1 reply

Userlevel 7
Badge +1

Hi Yannick!

Thanks for sharing your question here. Unfortunately it took me a bit to find out more about this, as I also was a bit confused that the editor offers the option to add a hyperlink to an image (and it also did not work in the tests I ran).

My colleagues have confirmed to me that the editor does currently not support adding hyperlinks to images - the behaviour when clicking on an image (enlarged detailed view) is correct.

Of course I have given the feedback that it is not ideal to then offer the hyperlink-menu when this is not supported, also that it would be nice to have this functionality added in the future.

So I hope that I will be able to give you an update on this once this is possible, however it does not seem to be something that can be added quick - also as there are other improvements to the editor which we regard as having a bigger impact on the editor experience (e.g. re-sizing images).

Reply